首页 / 同花顺公式 / 同花顺上涨牛逼指标公式

同花顺上涨牛逼指标公式

日期:2022-05-31 16:03:12

a1:=Ema(100*WINNER(CLOSE),5);//获利盘比例//

a11:=EMA(100*WINNER(CLOSE),10);//获利盘比例//

b1:=15;

C1:=80;

d1:=0;

e1:=HHV(a1,10);

SC1:=crOSS(a11,a1);SC2:=CROSS(C1,a1);JC1:=CROSS(a1,a11);JC22:=CROSS(a1,b1);

//动力差

zs:=REF(CLOSE,1);

zk:=REF(OPEN,1);

zg:=REF(HIGH,1);

zd:=REF(LOW,1);

Ll:=MA(CLOSE-zs+OPEN-zk+HIGH-zg+LOW-zd+CLOSE-OPEN,20),coloryellow;

L1l:SMA(CLOSE-zs+OPEN-zk+HIGH-zg+LOW-zd+CLOSE-OPEN,20,2),colorred;

zq:HHV(L1l,10),colorlired;

zq1:LLV(L1l,5),colorwhite;

DRAWTEXT(FILTER(CROSS(L1l,0) AND a1>10 AND REF(L1l,3)<0 AND zq>REF(zq,1),5),d1+0.1,"冲"),coloryellow;

DRAWTEXT(FILTER(JC22 AND L1l>0,8),d1-0.2,"飙"),colorred;

stICKLINE(L1l<0,L1l,0,1,1),colorliblue;

STICKLINE(L1l>0,L1l,0,1,1),colorred;

止跌:IF(L1l=zq AND L1l<0 AND zq>REF(zq,1),(0-L1l)*2,0),coloryellow;

STICKLINE(止跌>0 AND a1>a11,止跌,0,1,1),colormagenta;

TYP := (IF(ISNULL(HIGH),CLOSE,HIGH) + IF(ISNULL(LOW),CLOSE,LOW) + CLOSE)/3;

cci1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

DRAWTEXT(FILTER(止跌>0 AND a1>a11 AND CCI1<100,5),d1+0.1,"稳"),colormagenta;

DRAWTEXT(FILTER(止跌>0 AND a1<a11,9),d1+0.1,"预"),colorlired;

//持仓//

资金趋势:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),coloryellow,LINETHICK2;

VAR1:=HHV(HIGH,9)-LLV(LOW,9);

VAR2:=HHV(HIGH,9)-CLOSE;

VAR3:=CLOSE-LLV(LOW,9);

VAR4:=((VAR2)/(VAR1))*(100)-70;

VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);

VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);

VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);

VAR8:=LLV(LOW,34);

VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);

VAR10:=IF((VAR9>100),VAR9-100,0);

VAR11:=HHV(HIGH,34);

B11:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8)*4;

机构持仓:=EMA(B11,13),colorred;

z1:=(b11-机构持仓)*5;

DRAWTEXT(FILTER(CROSS(20,z1),5),d1-0.1,"废"),colorgreen;

DRAWTEXT(FILTER(止跌>0 AND a1>a11 AND CCI1<100 AND z1>0,5),d1-0.2,"启"),colormagenta;

//超买卖

//参数设置!//

TYP := (IF(ISNULL(HIGH),CLOSE,HIGH) + IF(ISNULL(LOW),CLOSE,LOW) + CLOSE)/3;

CCI1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

ca:=100,colorred;

cb:=-100,colorgreen;

cc:=0;

E1:=CROSS(cA,CCI1);

sg1:=e1 AND z1<REF(z1,1);//卖1震荡下降趋势用cci死叉//

//卖股!//

DRAWICON(FILTER(sg1 AND z1<250,2),d1-0.1,2);

DRAWTEXT(FILTER(sg1 AND z1<250 AND z1>111,2),d1-0.2,"警"),colorwhite;

DRAWTEXT(FILTER(sg1 AND z1<111,2 ),d1+0.2,"刹"),colorwhite;

DRAWTEXT(FILTER(zq1<REF(zq1,1) AND zq1>0 AND z1>0 AND zq<REF(zq,10) AND REF(zq,10)>REF(zq,15),5),zq+0.1,"减仓"),colorgreen;

DRAWTEXT(FILTER(zq1<REF(zq1,1) AND zq1>0 AND z1<0 AND zq<REF(zq,10) AND REF(zq,10)>REF(zq,15),5),zq+0.1,"报废"),colorgreen;

同花顺上涨牛逼指标公式