首页 / 通达信公式 / 通达信主力买卖持仓指标公式

通达信主力买卖持仓指标公式

日期:2022-07-02 14:04:15

AA:=vol/((HIGH-LOW)*2-Abs(CLOSE-OPEN));

买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;

卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;

进出量:=买量+卖量,COLOR00FFFF;stICKLINE(进出量<0,0,进出量,1,0),COLORFF6600;

STICKLINE(进出量<0,0,进出量,3,0),COLORFF9900;

STICKLINE(进出量<0,0,进出量,1.5,0),COLORFFCC00;

STICKLINE(进出量<0,0,进出量,0.5,0),COLORCYAN;

STICKLINE(进出量>0,0,进出量,3,0),COLOR000099;

STICKLINE(进出量>0,0,进出量,3,0),COLOR0000CC;

STICKLINE(进出量>0,0,进出量,1.0,0),COLOR0000FF;

STICKLINE(进出量>0,0,进出量,0.5,0),COLORCC66FF;N:=1;QJ0:= (HIGH+LOW+CLOSE)/3;

QJ1:=IF(HIGH=LOW,1,HIGH-maX(OPEN,CLOSE));

QJ2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-QJ0);

QJ3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);

QJ4:=IF(HIGH=LOW,1,QJ0-MIN(CLOSE,OPEN));

QJ5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));

QJ6:="macd.DIF">"MacD.DEA" AND "MACD.DEA"<0;

QJ7:="kdj.K">"kdJ.D" AND "KDJ.D"<30;

QJ8:="MACD.DIF"<"MACD.DEA";

QJ9:="KDJ.K"<"KDJ.D" AND "KDJ.K">80;

特大:QJ4*QJ5,NODRAW;大单:QJ3*QJ5,NODRAW;

中单:QJ1*QJ5,NODRAW;小单:QJ2*QJ5,NODRAW;

W1:=SUM(大单,N)+SUM(特大,N);W2:=SUM(小单,N)+SUM(中单,N);

量振1:=特大>大单 AND 大单>小单;

量振2:=特大<小单 AND 大单<小单;

标振1:=QJ6 AND QJ7;

标振2:=QJ8 AND QJ9;

A:=W1-W2;A0:=IF(A>0,A,0);B0:=IF(A<0,A,0);

STICKLINE(A0,0,A0,1,0),COLOR000044;主力持仓:EMA(100*(CLOSE- LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF;主力筹码集中度:WINNER(C)*100,COLORRED;

量比:SUM(V,BArslAST(TIME=930)+1)/(BARSLAST(TIME=930)+1)/DYNAINFO(16);

通达信主力买卖持仓指标公式