首页 / 通达信公式 / 通达信提前抄底部指标公式

通达信提前抄底部指标公式

日期:2022-07-02 14:04:09

{指标介绍:黄色曲线是多方力度;绿色曲线是空方力度。红色背景是耻骨区间;绿色背景是持币区间。股东的一些基本资料可以显示在左侧查询。底部出现粉红色的柱体表示庄家在吸纳筹码,这时候黄曲线突破5,就可以进行抄底动作。如果出现绿色钻石,抄底吧。}

本文指标含有选股公式如下:通达信提前抄底部指标公式此处内容已被隐藏,请输入验证码查看内容。验证码:请关注本站微信公众号,回复“1006”,获取验证码。

提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

强弱:=1;

短线M:=5;

吸筹:=1;

一阳:=1;

多线:=27;

空线:=55;

红钻:=1;

梅花:=1;

底部:=1;

解盘:=1;

逃顶:=1;

金银:=1;

P:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);

BB:=ma(P,3);

CC:=(SUM(IF((P > REF(P,1)),(P)*(vol),0),4))/(SUM(IF((P < REF(P,1)),(P)*(VOL),0),4));

DD:=REF(100 - (100)/(1 + CC),1);

A1:=HHV(P,15);

A2:=LLV(P,15);

A3:=A1 - A2;

A4:=(EMA((P - A2)/(A3),2))*(100);

多方力度1:=(3*SMA((CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,24)-LLV(LOW,24))*100,5,1),3,1))*强弱;

空方力度1:=(100*(HHV(HIGH,95)-CLOSE)/(HHV(HIGH,95)-LLV(LOW,95)))*强弱;

强:空方力度1<多方力度1,COLORRED;

stICKLINE(空方力度1<多方力度1,0,100,6.0,0)COLOR001050;

弱:STICKLINE(空方力度1>多方力度1,0,100,6.0,0)COLORLICYAN;

短线1:=A4;

短线:IF(CURRBARSCOUNT>短线M, DRAWNULL,短线1),COLORWHITE,LINETHICK1;

IF(短线>REF(短线,1),短线,DRAWNULL),LINETHICK1,COLORRED;

多方力度:(3*SMA((CLOSE-LLV(LOW,多线))/(HHV(HIGH,多线)-LLV(LOW,多线))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,多线))/(HHV(HIGH,27)-LLV(LOW,多线))*100,5,1),3,1)),COLOR00FFFF,LINETHICK2;

空方力度:100*(HHV(HIGH,空线)-CLOSE)/(HHV(HIGH,空线)-LLV(LOW,空线)),COLOR00EC00,LINETHICK1;

DRAWTEXT(ISLASTBAR,短线,'←短线'),COLORWHITE;

DRAWTEXT(ISLASTBAR,多方力度,'↖多方力度'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,空方力度,'↓←空方力度'),COLORGREEN;

持币:(IF(SAR(10,2,20)>=H,sar(10,2,20),DRAWNULL))*强弱,COLORCYAN,NODRAW;

持股:(IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL))*强弱,COLORRED,NODRAW;

STICKLINE(持币,50,45,2.1.1,0),COLORCYAN;

STICKLINE(持股,50,55,2.1.1,0),COLORRED;

买点:=REF(持币,1)>0 AND 持股>0,COLORLIRED;

DRAWTEXT(买点 AND 多方力度<=50,多方力度,'←买点'),COLORYELLOW;{LCY}

RSV:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA

((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

VAR2:=EMA(VAR1,8);

VAR3:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA

((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);

趋势:=EMA(VAR3,3)-10;

VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;

VAR5:=FILTER((趋势<=13 AND VAR4>13),10);

VAR6:=FILTER((趋势>=90 AND VAR4),10);

VAR7:=LLV(LOW,30);

VAR8:=HHV(HIGH,30);

VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;

VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;

VAR11:=SMA(Abs(LOW-REF(LOW,1)),3,1)/SMA(MAX(LOW-REF(LOW,1),0),3,1);

VAR12:=HHV(VAR11,30)*8;

VAR2222:=REF(LOW,1);

VAR3333:=(SMA(ABS(LOW-VAR2222),3,1))/(SMA(MAX(LOW-VAR2222,0),3,1))*100;

VAR4444:=EMA(IF(CLOSE*1.3,VAR3333*10,VAR3333/10),3);

VAR5555:=LLV(LOW,30);

VAR6666:=HHV(VAR4444,30);

VAR7777:=IF(MA(CLOSE,58),1,0);

主力吸筹:(EMA(IF(LOW<=VAR5555,(VAR4444+VAR6666*2)/2,0),3))/(618)*VAR7777,COLORMAGENTA,NODRAW;

VAR9999:=IF(主力吸筹>100,100,主力吸筹)*吸筹;

MA1:=MA(C,5);

MA2:=MA(C,10);

MA3:=MA(C,20);

MA4:=MA(C,60);

MA5:=MA(C,120);

筹码:=(COST(90)+COST(70)+COST(50)+COST(30)+COST(10))/5;

今获利:WINNER(C)*100,COLORWHITE,NODRAW;

昨获利:=REF(今获利,1),COLORYELLOW,NODRAW;

获利比增:今获利-昨获利,COLORRED,NODRAW;

二日涨幅:=(C-REF(C,5))/REF(C,5)*100;

五日涨幅:=(C-REF(C,5))/REF(C,5)*100;

十日涨幅:=(C-REF(C,10))/REF(C,10)*100;

二十涨幅:=(C-REF(C,20))/REF(C,20)*100;

十五涨幅:=(C-REF(C,15))/REF(C,15)*100;

六十涨幅:=(C-REF(C,60))/REF(C,60)*100;

量比:=V/REF(MA(V,1),1);

五日换手:=SUM(VOL,5)*100/CAPITAL;

二十换手:=SUM(VOL,20)*100/CAPITAL;

六十换手:=SUM(VOL,60)*100/CAPITAL;

趋势线:=(MA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,15)+MA(CLOSE,20))/4;

牛熊线:=MA(CLOSE,26);

生命线:=EMA(CLOSE,55);

AVAR10:=LLV(LOW,10);

AVAR13:=HHV(HIGH,25);

红线:=EMA((CLOSE-AVAR10)/(AVAR13-AVAR10)*4,4)*25;

A:=IF(空方力度1<多方力度1,红线,DRAWNULL),LINETHICK2,COLOR0000FF;

RSV10:=(HHV(HIGH,11)-CLOSE)/(HHV(HIGH,11)-LLV(LOW,11))*100;

绿线:=SMA(RSV10,3,1);

B:=IF(空方力度1<多方力度1,绿线,DRAWNULL),LINETHICK2,COLORWHITE;

多方辅助:IF(CURRBARSCOUNT>5, DRAWNULL,A)COLOR0000FF,LINETHICK2;

空方辅助:IF(CURRBARSCOUNT>5, DRAWNULL,B)COLORWHITE,LINETHICK2;

强势持股:IF(空方力度<空方辅助 AND 空方力度<50 AND 空方力度<多方辅助 AND 空方辅助<多方辅助,空方力度 AND 空方辅助<REF(空方辅助,1),DRAWNULL),LINETHICK1,COLORRED;

天:95,POINTDOT,COLORFFFF00;

界:=50,POINTDOT,COLORFFFFFF;

地:5,POINTDOT;

JD1:=MAX(MAX(趋势线,牛熊线),生命线);

JX1:=MIN(MIN(趋势线,牛熊线),生命线);

一阳定势:=(C>JD1 AND O<JX1 AND 量比>1 AND crOSS(多方力度,空方力度) AND C/REF(C,1)>1.02)*一阳,COLORRED,NODRAW;

金银袋:=(C>生命线 AND L <生命线 AND C>趋势线 AND CROSS(多方力度,空方力度) AND C/REF(C,1)>1.02 AND 量比>1.1 AND C>O AND H/MAX(O,C)<1.05)*金银,COLORYELLOW,NODRAW;

红钻石:=C/REF(C,1)>1.03 AND 量比>1.1 AND CROSS(多方力度,空方力度)*红钻,COLORLIRED,NODRAW;

STICKLINE(一阳定势,50,65,2.7.2,0),COLOR0000AA;

STICKLINE(一阳定势,50,65,1.9.4,0),COLOR0000BB;

DRAWICON(红钻石,35,25);

DRAWICON(金银袋,45,9);

A5:=((CLOSE - (LLV(LOW,9))) / ((HHV(HIGH,9)) - (LLV(LOW,9)))) * 100;

A6:=SMA(A5,3,1);

A7:=SMA(A6,3,1);

A17:=MA(CLOSE,90);

A26:=((CLOSE - A17) / A17) * 100;

RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K2:=SMA(RSV2,3,1);

D2:=SMA(K2,3,1);

A65:=(CROSS(K2,D2)) * 60;

A105:=MA(CLOSE,27);

A106:=((CLOSE - A105) / A105) * 100;

A107:=(MA(A106,3));

A149:=BArslAST(((CROSS(-10,A107)) = 1));

A150:=BARSLAST(((CROSS(A107,10)) = 1));

A151:=((A107 < -10) AND (A149 > 3));

A152:=((A107 > 10) AND (A150 > 3));

安全:=(((IF(A151,A107,0)) < 0) * -10),COLORGREEN;

STICKLINE(VAR9999>-150,0,VAR9999,2,0),COLORFF00FF;

龙抬头:=((((((A65 AND 安全) AND ((A6 - A7) > 1.5)) AND (OPEN != HIGH)) AND (A26 < -10)) OR (安全 AND (CROSS(A6,A7)))) * 20)*梅花;

IF(龙抬头,6,DRAWNULL),CROSSDOT,LINETHICK6,COLORRED;

趋势线2:=MA((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,2);

钻石底:=(趋势线2<-20)*底部,COLORLIGREEN,NODRAW;

DRAWICON(钻石底,2,27);

VARL1:=(HIGH+LOW+CLOSE)/3;

VARL2:=(VARL1-MA(VARL1,14))/(0.015*AVEDEV(VARL1,14));

VARL3:=(VARL1-MA(VARL1,70))/(0.015*AVEDEV(VARL1,70));

VARL4:=IF(VARL2>=150 AND VARL2<200 AND VARL3>=150 AND VARL3<200,10,0);

VARL5:=IF(VARL2<=-150 AND VARL2>-200 AND VARL3<=-150 AND VARL3>-200,-10,VARL4);

PJX:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

短期强弱:=PJX;

VARL1A:=IF(PJX>0,PJX,0);

VARL1B:=IF(VARL3>=200 AND VARL2>=150,15,IF(VARL3<=-200 AND VARL2<=-150,-15,VARL5));

抄底:REF(VARL1B=-15,1) AND VARL1B>-15,NODRAW;

DRAWTEXT(抄底,5,' ★抄底'),COLORYELLOW;

VAR01:=(HIGH+LOW+CLOSE)/3;

VAR02:=(VAR01-MA(VAR01,14))/(0.015*AVEDEV(VAR01,14));

VAR03:=(VAR01-MA(VAR01,70))/(0.015*AVEDEV(VAR01,70));

VAR04:=IF(VAR02>=150 AND VAR02<200 AND VAR03>=150 AND VAR03<200,10,0);

VAR05:=IF(VAR02<=-150 AND VAR02>-200 AND VAR03<=-150 AND VAR03>-200,-10,VAR04);

VAR1B:=(IF(VAR03>=200 AND VAR02>=150,15,IF(VAR03<=-200 AND VAR02<=-150,-15,VAR05))+60)*逃顶;

DRAWTEXT(FILTER(VAR1B=75,5),95,'★逃顶'),COLORLIGREEN;

{通达信指标副图,指标名称:机构股东等}

流通A股:=FINONE(239,0,0);

前期机构占比:=FINONE(247,0,331)/流通A股*100;

本期机构占比:=FINONE(247,0,0)/流通A股*100;

机构持股增减:=本期机构占比-前期机构占比;

前期股东占比:=FINONE(264,0,331)/流通A股*100;

本期股东占比:=FINONE(264,0,0)/流通A股*100;

股东持股增减:=本期股东占比-前期股东占比,COLORFFFFFF;

前股东人数:=FINONE(242,0,331);

本股东人数:=FINONE(242,0,0);

持股人数增减:=(本股东人数-前股东人数)/前股东人数*100;

前期机构家:=FINONE(246,0,331);

本期机构家:=FINONE(246,0,0);

DRAWTEXT_FIX(1,0.0,0.00,0,STRCAT('前期机构持股占比:',CON2STR(前期机构占比,2))),COLORYELLOW;

DRAWTEXT_FIX(1,0.0,0.08,0,STRCAT('本期机构持股占比:',CON2STR(本期机构占比,2))),COLORYELLOW;

DRAWTEXT_FIX(1,0.16,0.00,0,STRCAT('前期 机构(家):',CON2STR(前期机构家,2))),COLORYELLOW;

DRAWTEXT_FIX(1,0.16,0.08,0,STRCAT('本期 机构(家):',CON2STR(本期机构家,2))),COLORYELLOW;

DRAWTEXT_FIX(1,0.0,0.16,0,STRCAT('机构持股占比增减:',CON2STR(机构持股增减,2))),COLORRED;

DRAWTEXT_FIX(1,0.0,0.28,0,STRCAT('前期十大流东股东持股占比:',CON2STR(前期股东占比,2))),COLORCYAN;

DRAWTEXT_FIX(1,0.0,0.36,0,STRCAT('本期十大流东股东持股占比:',CON2STR(本期股东占比,2))),COLORCYAN;

DRAWTEXT_FIX(1,0.0,0.44,0,STRCAT('十大流东股东持股占比增减:',CON2STR(股东持股增减,2))),COLORRED;

DRAWTEXT_FIX(1,0.0,0.56,0,STRCAT('前股东人数:',CON2STR(前股东人数,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.0,0.64,0,STRCAT('本股东人数:',CON2STR(本股东人数,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.0,0.72,0,STRCAT('持股人数增减比:',CON2STR(持股人数增减,2))),COLORRED;

通达信提前抄底部指标公式