首页 / 通达信公式 / 通达信A股波段王主图指标公式

通达信A股波段王主图指标公式

日期:2022-06-23 14:03:16

ma25:=MA(C,25);

EMA135:=EMA(C,135);

EMA250:=EMA(C,250);

涨停:=C>=ZTPRICE(REF(C,1),0.1);

LINE1:=MA25; {简单移动平均线 25日}

LINE2:=EMA250; {指数移动平均线 250日}

LINE3:=EMA135; {指数移动平均线 135日}

stICKLINE(NOT(涨停) AND C>LINE1 AND C>O,C,O,3,1),COLOR15CFD9;

STICKLINE(NOT(涨停) AND C<LINE1,C,O,3,0),COLORD32C5E;

STICKLINE(涨停,C,O,3,1),COLOR00FFFF;

STICKLINE(涨停,L,H,0.3,1),COLOR00FFFF;

STICKLINE( C>LINE1 AND H>=REF(H,1),LINE1*1.02,LINE1,0.3,0),COLOR00FFFF;

STICKLINE( C<LINE1,H,LINE1,0.3,0),COLORFF8080;

L01A:LINE1,LINETHICK3,COLOR0000FF;

L01B:IF(C<LINE1,LINE1,DRAWNULL),LINETHICK3,COLOR00FF00;

DRAWICON(crOSS(LINE2,C),LINE2,23);

DRAWICON(CROSS(LINE3,C),LINE3,23);

牛熊135A: LINE3,LINETHICK3,COLOR000080;

牛熊135B: IF(C<LINE3,LINE3,DRAWNULL),LINETHICK3,COLOR008000;

牛熊250A: LINE2,LINETHICK3,COLORC0C0C0;

牛熊250B: IF(C<LINE2,LINE2,DRAWNULL),LINETHICK3,COLORFF0080;

通达信A股波段王主图指标公式