首页 / 通达信公式 / 通达信神器分时主图指标公式

通达信神器分时主图指标公式

日期:2022-05-20 14:07:37

攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;

攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),COLOR0000FF,LINETHICK0;

攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;

攻击流量:=攻击量A+攻击量B,COLORstICK;

攻击比:=攻击流量/SUM(V,FROMOPEN)*100,COLORRED,LINETHICK1;

资金攻击:=IF(攻击比>=0,(攻击比+50),100-Abs((攻击比-50)));

资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),STICK,COLORRED;

资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;

资金出入:=资金流入+资金流出,COLORSTICK;

资金比:=资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;

资金流比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));

DRAWTEXT_FIX(1,0.180,0.88,0,STRCAT(STRCAT('【资金流比】',CON2STR(资金流比,2)),'%买')),COLORYELLOW;

DRAWTEXT_FIX(1,0.000,0.88,0,STRCAT(STRCAT('【资金攻击】',CON2STR(资金攻击,2)),' %买')),COLORYELLOW;

XG:HHV(H,480),DOTLINE,COLORRED;

STICKLINE(FILTER(crOSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,C,8,0),COLORGREEN;

DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,'突破'),COLORYELLOW;

RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;

JY:=BArslAST((RQ-REF(RQ,1))!=WEEkdAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;

ma1:=REF(C,JY);

MA2:=REF(MA1,JY);

MA3:=REF(MA2,JY);

MA4:=REF(MA3,JY);

MA5:=REF(MA4,JY);

MA6:=REF(MA5,JY);

MA7:=REF(MA6,JY);

MA8:=REF(MA7,JY);

MA9:=REF(MA8,JY);

CK:REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE),COLORac59FF,CIRCLEDOT;

DRAWTEXT(ISLASTBAR,CK,' 参考线'),COLOR0000FF;

DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);

DEA:=EMA(DIF,9);

macd1:=10*(DIF-DEA);

MACD2:=EMA(MACD1,2);

STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR0000B4;

STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR00B400;

STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR5151A2;

STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR88743A;

XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));

主力:=expma(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);

底:=1;1.02,NODRAW;高:=1.03;

DRAWTEXT(CROSS(主力,1.02),C*0.999,'-拉升'),COLORCYAN;

DRAWICON(CROSS(主力,1.04),C,24);

DRAWTEXT(CROSS(主力,1.04),C*0.999,'-冲涨停'),COLORLIMAGENTA;

A1:=(vol/CLOSE)/3;

A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A5:=SUM((IF(((A1<40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A6:=((A2+A3)+A4)+A5;

A7:=IF((BARSTATUS=2),((100*A2)/A6),0);

A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));

A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));

A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));

机构买盘:=(A2),LINETHICK2;

机构卖盘:=(A3),LINETHICK2;

散户买盘:=(A4);

散户卖盘:=(A5);

DRAWTEXT_FIX(1,0.0,1-0.05,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万')),COLORYELLOW;

DRAWTEXT_FIX(1,0.18,1-0.05,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),'万')),COLOR00FF00;

DRAWTEXT_FIX(1,0.36,1-0.05,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),'万')),COLORYELLOW;

DRAWTEXT_FIX(1,0.54,1-0.05,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万')),COLOR00FF00;

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:=L1+P1*7/8,COLORGREEN;

支撑:=L1+P1*0.5/8,COLORMAGENTA;

DRAWTEXT(LONGCROSS(支撑,C,2),C,'买'),COLORYELLOW;

DRAWTEXT(LONGCROSS(C,阻力,2),C,'卖'),COLORGREEN;

量价:=(VOL/CLOSE)/3;

B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);

B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);

B6:=B2+B3;DD1:=1;比:=B2/B3;

BBB1:=STRCAT(STRCAT('买= ',CON2STR((100*B2)/B6,0)),'%'),COLORYELLOW;

BBB2:=STRCAT(STRCAT('卖= ',CON2STR((100*B3)/B6,0)),'%');

BBB3:=STRCAT(STRCAT('差= ',CON2STR((100*(B2-B3))/B6,0)),'%');

DRAWTEXT_FIX(DD1=1,0,0.70,0,BBB1),COLORRED;

DRAWTEXT_FIX(DD1=1,0,0.75,0,BBB2),COLORGREEN;

DRAWTEXT_FIX(DD1=1,0,0.80,0,BBB3),COLOR00FFFF;

市销率:=STRCAT('市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));市净率:=STRCAT('市净率: ',CON2STR(C/FINANCE(34),2));

净资收益率:=STRCAT('净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));毛利率:=STRCAT('毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));

净利润率:=STRCAT('净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));主营利润率:=STRCAT('主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));利润同比:=STRCAT('利润同比: ',CON2STR(FINANCE(43),2));收入同比:=STRCAT('收入同比: ',CON2STR(FINANCE(44),2));X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;X3:=FINANCE(23)/FINANCE(10)*3.3;X4:=FINANCE(19)/FINANCE(15)*0.6;X5:=FINANCE(20)/FINANCE(15)*0.999;

Z值:=X1+X2+X3+X4+X5;预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));

优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));

财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));DRAWTEXT_FIX(ISLASTBAR,0.50,0.05,0,财务系数),COLORYELLOW;D1:=YEAR AND MONTH AND DAY;AA1:=STRCAT(CON2STR(YEAR,0),'年');

AA2:=STRCAT(CON2STR(MONTH,0),'月');AA3:=STRCAT(CON2STR(DAY,0),'日');AA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));

AA:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'');DRAWTEXT_FIX(D1,0.888,0.001,0,AA),COLORLIGRAY;

MZ0:=(BARSLAST(((HOUR=9) AND (MINUTE=31)))+1);

上穿分时:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*HHV(CLOSE,0)),0))),DRAWNULL)LINETHICK1,COLORBLACK;

底支:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*LLV(CLOSE,0)),0))),DRAWNULL),LINETHICK1,COLORBLACK;

STICKLINE(TIME=931 OR TIME=1000,上穿分时,底支,0,-1),COLORLIBLUE;分时上突:=CROSS(C,上穿分时);上突:=C<上穿分时 AND 上穿分时>底支;DRAWICON(分时上突,C,5);股价支撑线:=MA(CLOSE,20);

底价线:股价支撑线-2*STD(CLOSE,20),NODRAW,COLORMAGENTA,LINETHICK2;DRAWTEXT_FIX(1,0.0001,0.00,0,STRCAT(STRCAT('【今日强势有效突破】',CON2STR(上穿分时,2)),' 元买入稳赚')),COLORWHITE,LINETHICK1;

DRAWTEXT_FIX(1,0.5001,0.00,0,STRCAT(STRCAT('【底部得到有效支撑】',CON2STR(底支,2)),' 元 可以参考')),COLORWHITE,LINETHICK1;

所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.05,0,所属板块),COLORWHITE;

主营收入同比:=FINANCE(44);{主营收入同比增长率}

净利润同比:=FINANCE(43);{净利润同比增长率}

市盈:=DYNAINFO(39);

市净:=CONST(DYNAINFO(7) / FINANCE(34));

净利:=CONST(FINANCE(30)/FINANCE(20));

DRAWTEXT_FIX(1,0.72,0.71,0,'市盈:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.79,0.71,0,CON2STR(市盈,2)),COLORRED;

DRAWTEXT_FIX(1,0.72,0.77,0,'市净:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.79,0.77,0,CON2STR(市净,2)),COLORWHITE;

DRAWTEXT_FIX(1,0.72,0.83,0,'净利:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.79,0.83,0,CON2STR(净利,2)),COLORWHITE;

DRAWTEXT_FIX(1,0.72,0.89,0,'主营同比:'),COLORWHITE;

DRAWTEXT_FIX(1,0.79,0.89,0,STRCAT(VAR2STR(主营收入同比,0),' %')),COLORYELLOW;

DRAWTEXT_FIX(1,0.72,0.95,0,'净利同比:'),COLORWHITE;

DRAWTEXT_FIX(1,0.79,0.95,0,STRCAT(VAR2STR(净利润同比,0),' %')),COLORYELLOW;

换手:=VOL/CAPITAL*100;

五换:=MA(换手,5);

DRAWTEXT_FIX(1,0.87,0.71,0,'今换:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.91,0.71,0,STRCAT('',CON2STR(换手,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.87,0.77,0,'五换:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.91,0.77,0,STRCAT('',CON2STR(五换,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.87,0.83,0,'量比:'),COLORWHITE;

DRAWTEXT_FIX(1,0.91,0.83,0,STRCAT('',CON2STR(DYNAINFO(17),2))),COLORRED;

DRAWTEXT_FIX(1,0.87,0.89,0,'内盘:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.91,0.89,0,STRCAT('',CON2STR(DYNAINFO(22),0))),COLORGREEN;

DRAWTEXT_FIX(1,0.87,0.95,0,'外盘:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.91,0.95,0,STRCAT('',CON2STR(DYNAINFO(23),0))),COLORRED;

通达信神器分时主图指标公式