首页 / 通达信公式 / 通达信主力异动进入指标公式

通达信主力异动进入指标公式

日期:2022-05-20 14:07:23

VA1:=Ema(EMA(CLOSE,9),9);

VA2:=(VA1-REF(VA1,1))/REF(VA1,1)*1000;

VA3:=crOSS(VA2,0);

VA4:=MA(C,120);

VA5:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);

VA6:=IF(CLOSE>VA4 AND REF(VA5,1)<30 AND VA5>REF(VA5,1) AND REF(VA5,1)<REF(VA5,2),10,0);

主力异动进入:VA3 AND VA6;

{抓连扳}

ZDF:=(C-REF(C,1))/REF(C,1)*100;

S0:=INBLOCK('创业板');

S1:=IF(NAMELIKE('S'),0,1);

S2:=IF(NAMELIKE('*'),0,1);

S3:=vol/CAPITAL*100;

S4:=S3*((H-L)+Abs(C-O));

S5:=S4/C;

S6:=NOT(S0) AND S1 AND S2;

抓连扳:S5<1.6 AND S6 AND ZDF>9.82;

{黑盘手牛股}

M1:=V/700000000;

M2:=1.1*(MAX(H,REF(C,1))/MIN(L,REF(C,1))-1);

M3:=2.5*MAX(M1,M2);

M4:=DMA(C,M3);

M5:=SMA(20*(M4/REF(M4,1)-1),2,1);

M6:=EMA(M5,2);

M7:=0.24;

M8:=C>=REF(C,1);

XX:= IF(M5>M7 AND M6>=0.005 AND M8,1,0);

XXX:=CROSS(XX,0.5) AND COUNT(XX>0.5,10)=1;

QB:="kdj.J"-REF("kdJ.J",1)>30 AND C/REF(C,1)>1.043 AND "macd.MacD">0 AND "MACD.DEA">0;

LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAst(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));

LQ:=FILTER(LS,28)*100 AND L>REF(C,1)*0.93;

XG:=QB OR LQ AND XXX;

M11:=9;

M12:=10;

B1:=C/REF(C,1)>1+0.01*M11;

B2:=EXIST(C/REF(C,1)>1+0.01*M11,M12);

B3:=C/REF(C,1)>1+0.01*M11;

MM:=IF(B1+B2+B3=3,1,0);

CC:=(H-C)/(C-O)<0.33;

DD:=(C/REF(C,1)-1)>=0.0502 AND C>REF(C,1) AND (O-L)/(C-O)>=1.48 AND L<REF(L,1) AND L<REF(L,2);

EE:=(C/REF(C,1)-1)>=0.08;

AA:=V>REF(V,1)*1.9 AND C>REF(C,1) AND C/REF(C,1)-1>=0.049 AND CC;

BB:=(C/REF(C,1)-1)>=0.0502 AND C>REF(C,1) AND V>REF(V,1) AND V>REF(V,1)*2.5 AND CC;

CCB:=EMA(2.055*EMA(EMA(H,34),34)-EMA(EMA(L,34),34),5),COLORCYAN,LINETHICK2;

YDXG:=IF(FILTER(AA OR BB OR DD OR EE AND CCB>C,34),1,0) AND MM;

LYQD:IF(XG OR YDXG,1.2,0),STICK,COLORMAGENTA,LINETHICK4;

DRAWTEXT(CROSS(LYQD,1),LYQD-LYQD*0.14,' 牛股预警'),COLORMAGENTA;

{STICKLINE(LYQD,C,O,3,0),COLORMAGENTA;

DRAWICON(LYQD,L,25);};

通达信主力异动进入指标公式