首页 / 通达信公式 / 通达信致富脱贫线指标公式

通达信致富脱贫线指标公式

日期:2022-04-07 14:08:41

X_1:=3;

X_2:=IF(CODELIKE(2) AND DATE>1200823 OR CODELIKE(3),1,0);

X_3:=CLOSE>=ZTPRICE(REF(CLOSE,1),IF(X_2>0,0.2,0.1));

X_4:=MA(CLOSE,10)*(1+IF(X_2=1,20,10)/100);

X_5:=MA(MA(LOW,X_1),X_1);

X_6:=HHV(X_5,5);

致富线:EMA(CLOSE,6)-EMA(CLOSE,13),COLORBLUE,LINETHICK2;

脱贫线:REF(HHV(致富线,X_1),1),COLORGREEN,LINETHICK2;

X_7:=Abs(ATAN((致富线/REF(致富线,1)-1)*100)*180/3.141593);

NOTEXT1:IF(致富线>EMA(脱贫线,1),致富线,DRAWNULL),COLORYELLOW,LINETHICK3;

NOTEXT2:IF(致富线>EMA(脱贫线,1) AND X_5>=REF(X_6,1) AND CLOSE>=X_4 AND X_3,致富线,DRAWNULL),COLORRED,LINETHICK3;

选股:REF(致富线>EMA(脱贫线,1) AND X_5>=REF(X_6,1) AND CLOSE>=X_4 AND X_3,1)*(OPEN>REF(CLOSE,1)*1.029)*(OPEN<REF(CLOSE,1)*1.069),NODRAW;

DRAWICON(致富线>脱贫线 AND X_7>72 AND X_3,致富线,1);

DRAWICON(crOSS(脱贫线,致富线) AND REF(X_3,1),致富线*1.1,2);

DRAWICON(选股,脱贫线,23);

DRAWICON(致富线>EMA(脱贫线,1) AND X_5>=REF(X_6,1) AND CLOSE>=X_4 AND X_3,脱贫线,34);

通达信致富脱贫线指标公式