首页 / 通达信公式 / 通达信牛马BS波段主图指标公式

通达信牛马BS波段主图指标公式

日期:2022-04-06 14:02:11

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

牛线: (20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;

马线:MA(牛线,6),COLORGREEN;

水平面:MA(CLOSE,60),POINTDOT,COLORYELLOW;

MS:IF(牛线>=REF(牛线,1),牛线,DRAWNULL),COLORRED,LINETHICK2;

MM:IF(马线>=REF(马线,1),马线,DRAWNULL),COLORYELLOW,LINETHICK2;

买:=crOSS(牛线,马线);

卖:=CROSS(马线,牛线);

DRAWICON(买,L*0.97,1);

DRAWTEXT(买,L*0.95,'B'),COLORYELLOW;

DRAWICON(卖,H*1.03,2);

DRAWTEXT(卖,H*1.05,'S'),COLORWHITE;

通达信牛马BS波段主图指标公式