首页 / 通达信公式 / 通达信步入抄底区指标公式

通达信步入抄底区指标公式

日期:2021-12-17 20:00:07

N:=55;
C2:=REF(CLOSE,1);
非st涨停:=IF((CLOSE-C2)*100/C2>=10-0.01*100/C2,1,0);
NUMBER:=COUNT(非ST涨停,BARSSINCE(非ST涨停)+1);
TDXSTEP195:DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.56,0.02,0,NUMBER),COLORWHITE;
TDXSTEP196:DRAWTEXT_FIX(CURRBARSCOUNT=1,0.45,0.02,0,25),COLORCYAN;
M5:ema(CLOSE,5);
M21:ma(CLOSE,21),COLORCYAN;
DD:=EVERY(CLOSE<MA(CLOSE,21),20);
TDXSTEP197:DRAWICON(DD,M21,37);
HIGHN:=36;
AAB:=REF(HIGH,HIGHN)=HHV(HIGH,2*HIGHN+1);
QY:=BacKSET(AAB,HIGHN+1);
CC2:=FILTER(QY,HIGHN) AND HIGH=HHV(HIGH,HIGHN+1);
DDD:=BArslAST(CC2);
GDTS:=IF(CC2,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DRAWLINE(CURRBARSCOUNT=GDCS1,HIGH,ISLASTBAR,REF(HIGH,GDCS1-1),1),DOTLINE,COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=GDCS1,HIGH*1.01,18),COLORCYAN;

通达信步入抄底区指标公式