首页 / 通达信公式 / 通达信逆向操作指标公式

通达信逆向操作指标公式

日期:2021-12-17 20:00:07

VE:=REF(LOW,1)*0.9;
VF:=LOW*0.9;
V10:=(VF*vol+VE*VOL);
V11:=ema(V10,30);
V12:=V11-CLOSE;
V13:=REF(CLOSE,1);
V14:=SMA(maX(CLOSE-V13,0),7,1)/SMA(Abs(CLOSE-V13),7,1)*100;
V15:=SMA(MAX(CLOSE-V13,0),13,1)/SMA(ABS(CLOSE-V13),13,1)*100;
V16:=BARSCOUNT(CLOSE);
V17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
V18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
V19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
V1A:=(SMA(V19,4,1)-50)*2;
V1B:=SMA(V1A,3,1);
V1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
V1D:=SMA(V1C,4,1);
V1E:=SMA(V1D,3,1);
V1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
V20:=V17<=25 AND V18<-95 AND V1F>20 AND V1B<-30 AND V1E<30 AND V12>=-0.25 AND V14<22 AND V15<28 AND V16>50;
stICKLINE(V20,0,80,0,0),COLORRED,LINETHICK4;
V1:=MA(100*(C-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
V2:=2*ABS(V1);
V3:=(100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1));
V4:=(100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1));
STICKLINE(REVERSE(-1*V3)<=REF(REVERSE(-1*V4),1),REVERSE(-1*V3),REVERSE(-1*V4),8,0),COLORRED;
STICKLINE(REVERSE(-1*V3)>REF(REVERSE(-1*V4),1),REVERSE(-1*V3),REVERSE(-1*V4),8,0),COLORWHITE;
V5:=(HIGH+LOW+CLOSE)/3;
V6:=(V5-MA(V5,14))/(0.015*AVEDEV(V5,14));
V7:=(V5-MA(V5,70))/(0.015*AVEDEV(V5,70));
V8:=IF(V6>=150 AND V6<200 AND V7>=150 AND V7<200,10,0);
V9:=IF(V6<=-150 AND V6>-200 AND V7<=-150 AND V7>-200,-10,V8);
VA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VB:=100-ABS(VA);
VC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
趋势:V3,NODRAW;
顶线:IF(VB<90,VB,100),COLORGREEN;
多方:IF(V1>-1,V1,0),LINESTICK,COLORMAGENTA;
空方:REVERSE(-1*IF(V1<-1,V2,0)),LINESTICK,COLORGREEN;
抄底:V20;
导弹:IF(V20,80,0),COLORRED,NODRAW;
预警系统:(IF((V7>=200 AND V6>=150) OR crOSS(75,多方),15,IF(V7<=-200 AND V6<=-150,-15,V9))+60),COLORYELLOW,LINETHICK2;

通达信逆向操作指标公式