首页 / 通达信公式 / 通达信陶氏TWX主图指标公式

通达信陶氏TWX主图指标公式

日期:2021-12-17 18:28:46

N:=9;
随机值:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
KSMA:=Sma(随机值,3,1);
DSMA:=SMA(KSMA,3,1);
M1:=N-1;
F:=HHV(HIGH,M1)-LLV(LOW,M1);
K:=KSMA/3*2+(CLOSE-LLV(LOW,M1))/F*100/3;
D:=DSMA/3*2+K/3;
J:=3*K-2*D;
X1:=(J*9+DSMA*12-KSMA*14)*F/700+LLV(LOW,M1);
X3:=IF(CLOSE>500,100,1);
X4:=IF(CLOSE>500,1,10);
高价:(F*80/100+LLV(LOW,M1)),LINETHICK2;
{股旁网-股票公式网站 www.gupang.com}
现价:X1,COLORRED;
kd:((DSMA*3-KSMA*2)*F/100+LLV(LOW,M1)),COLORFF00FF;
低价:(F*20/100+LLV(LOW,M1)),LINETHICK2;
MA13:=MA(X1,13);
买1:=crOSS(现价,KD) AND kdj.J<20;
买2:=CROSS(现价,低价) AND KDJ.J<30;
卖1:=CROSS(高价,现价) AND KDJ.J>80;
卖2:=CROSS(KD,现价) AND KDJ.J>80;
LIFE1:MA(C,13),COLORYELLOW,POINTDOT,LINETHICK5;
LIFE2:MA(X1,55),CROSSDOT,LINETHICK2;
DRAWTEXT(买2,L*0.99, '▲买1'),COLORRED;
DRAWTEXT(买1,L*0.99, '△买2'),COLORYELLOW;
DRAWTEXT(卖1,H*1.02, '◆卖1'),COLORGREEN;
DRAWTEXT(卖2,H*1.02, '◇卖2'),COLORCYAN;

通达信陶氏TWX主图指标公式