首页 / 股票公式答疑 / 把几个信号选股放在一栏 高底错落有致

把几个信号选股放在一栏 高底错落有致

日期:2021-12-22 17:58:06

编写条件:

请 高手 帮 帮 象下面的效果 月K:="KDJ.K#MONTH"; 月D:="KDJ.D#MONTH"; 周K:="KDJ.K#WEEK"; 周D:="KDJ.D#WEEK"; 日K:="KD.K"; 日D:="KD.D"; 日金叉:=IF(CROSS(日K,日D),15,0),COLORWHITE; 周金叉:IF(CROSS(周K,周D),15,0),COLORYELLOW; 月金叉:IF(CROSS(月K,月D),35,0),COLORRED; DRAWICON(周金叉 AND 日金叉,5,1); DRAWICON(周金叉 AND 月金叉,15,7); DRAWICON(日金叉 AND 月金叉,25,21); 这 几个 ,是加 数字 吗 有 方法 更 好 感谢 A18:=(EMA(CLOSE,2)); A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42)); A20:=(HHV((MA(HIGH,13)),13)); A21:=(LLV((MA(HIGH,13)),1)); A22:=(EMA(CLOSE,4)); A23:=((((A18>= A19) AND (A21 = A20)) AND (A18> A22)) AND (CLOSE> A21)) AND ((REF(A21,1)) < (REF(A20,1))); A24:=BARSLAST(A23)+1; A25:=(LLV(LOW,A24))*1.3; A26:=(LLV(LOW,20))*1.418; A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26); A28:=A27 AND (FILTER(A27,A24)); A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ; A31:=A30 AND (FILTER(A30,20)); XG:A28 OR A31; MA3:=MA(C,3); MA5:=MA(C,5); MA10:=MA(C,10); MA20:=MA(C,20); 角度MA3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416; 角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416; 角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416; 角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416; 选:IF(角度MA3>45 AND 角度MA5>45 AND 角度MA10>45 AND 角度MA20>20 AND MA(C,1)>REF(MA(C,1),1), 1,0),COLORGREEN; 大盘超跌:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100*1.1; Y:=10; XG:CROSS(大盘超跌,10)COLORGREEN;

编写方法:

A18:=(ema(CLOSE,2));

A19:=(Ema((((SLOPE(CLOSE,21))*20)+CLOSE),42)); A20:=(HHV((MA(HIGH,13)),13)); A21:=(LLV((MA(HIGH,13)),1)); A22:=(EMA(CLOSE,4)); A23:=((((A18 >= A19) AND (A21 = A20)) AND (A18 > A22)) AND (CLOSE > A21)) AND ((REF(A21,1)) < (REF(A20,1))); A24:=BArslAst(A23)+1; A25:=(LLV(LOW,A24))*1.3; A26:=(LLV(LOW,20))*1.418; A27:=(((((A18 >=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26); A28:=A27 AND (FILTER(A27,A24)); A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ; A31:=A30 AND (FILTER(A30,20)); XG:(A28 OR A31)*2.5; MA3:=MA(C,3); MA5:=MA(C,5); MA10:=MA(C,10); MA20:=MA(C,20); 角度MA3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416; 角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416; 角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416; 角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416; 角度选:(角度MA3>45 AND 角度MA5>45 AND 角度MA10>45 AND 角度MA20>20 AND MA(C,1)>REF(MA(C,1),1))*5,COLORYELLOW; 大盘超跌:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100*1.1; Y:=10; 大盘XG:crOSS(大盘超跌,10)*10,COLORGREEN;