首页 / 股票公式答疑 / 将决策和majcqx同时上穿56设为预警

将决策和majcqx同时上穿56设为预警

日期:2021-12-22 17:58:05

编写条件:

源码MA1:=MA(CLOSE,5); MA2:=MA(CLOSE,10); P01:=IF(MA1>MA2,1,IF(MA2>MA1,-1,0)); MA3:=MA(CLOSE,3); MA4:=MA(CLOSE,5); P02:=IF(MA3>MA4,1,IF(MA4>MA3,-1,0)); MA5:=MA(CLOSE,12); MA6:=MA(CLOSE,50); P03:=IF(MA5>MA6,1,IF(MA6>MA5,-1,0)); {KDJ} RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100; K:=EMA(RSV,3); D:=EMA(K,3); P04:=IF(K>D,1,IF(D>K,-1,0)); {MACD} DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); MACD:=(DIF-DEA)*2; P05:=IF(DIF>DEA,1,IF(DEA>DIF,-1,0)); {TRIX} TR2:=EMA(EMA(EMA(CLOSE,12),12),12); TRIX:=(TR-REF(TR,1))/REF(TR,1)*100; MATRIX:=MA(TRIX,9) ; P06:=IF(TRIX>MATRIX,1,IF(MATRIX>TRIX,-1,0)); {DMI} TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),7); HD :=HIGH-REF(HIGH,1); LD :=REF(LOW,1)-LOW; DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),7); DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),7); PDI:= DMP*100/TR; MDI:= DMM*100/TR; ADX:= EMA(ABS(MDI-PDI)/(MDI+PDI)*100,7); ADXR:=EMA(ADX,7); P07:=IF(PDI>MDI AND ADX>PDI AND ADX>50,3, IF(PDIMDI AND ADX>50,-3,0));{9} {RSI} LC:=REF(CLOSE,1); RSI1:=EMA(MAX(CLOSE-LC,0),5)/EMA(ABS(CLOSE-LC),5)*100;{10} P08:=IF(RSI1>80,1,IF(RSI1<20,-1,0));{10} {CCI} TYP:=(HIGH+LOW+CLOSE)/3; CCI:=(TYP-MA(TYP,8))/(0.015*AVEDEV(TYP,8)); P09:=IF(CCI>180,2,IF(CCI<-180,-2,0));{12} {W%R} WR1:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100; P10:= IF(WR1>80,1,IF(WR1<20,-1,0));{13} {OSC} OSC:=100*(CLOSE-MA(CLOSE,20)); P11:=IF(OSC>0,1,IF(OSC<0,-1,0));{14} {MTM} MOM:=CLOSE-REF(CLOSE,7); P12:=IF(MOM>0,1,IF(MOM<0,-1,0));{15} {DPO} DPO:=CLOSE-REF(MA(CLOSE,11),11/2+1); P13:=IF(DPO>0,1,IF(DPO<0,-1,0));{16} {布林线} MB:=MA(CLOSE,12); R:=(CLOSE-MB)*(CLOSE-MB); X1:=MA(R,12); X2:=SQRT(X1); D1:=1; UPPER:=MB+(D1*X2); LOWER:=MB-(D1*X2); P14:=IF(CLOSE>UPPER,2,IF(CLOSE350 OR AR>180,3,IF(BR<45 OR AR<45,-3,0));{21} {VR} TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),14); TL:=SUM(IF(CLOSE350,3,IF(VR<45,-3,0));{24} {WVAD} WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,6)/10000; P17:=IF(WVAD>0,1,IF(WVAD<0,-1,0));{25} {EMV} VOLUME:=MA(VOL,4)/VOL; MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW); EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,4),4); P18:=IF(EMV>0,1,IF(EMV<0,-1,0));{26} {OBV} VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL); OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0); MAOBV:=EMA(OBV,24); P19:=IF(OBV>MAOBV,1,IF(OBVMPVI,1,IF(PVIMNVI,2,IF(NVIREF(MA7,1) AND MASS>26.5,2,IF(MA7VHF1,1,IF(VHFREF(逆时针,1),1,IF(逆时针BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4)); X01:=(CLOSE-LC2+(CLOSE-OPEN)/2+LC2-REF(OPEN,1)); SI:=16*X01/R2*MAX(AA,BB); ASI:=SUM(SI,0),COLORWHITE; MASI:=MA(ASI,6),COLORYELLOW; P25:=IF(CLOSELLV(CLOSE,13) AND ASI=LLV(ASI,13),-1,0)); {BIAS} BIAS1 :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100; P26:=IF(BIAS1>10,1,IF(BIAS1<-10,-1,0)); 决策: (36+P01+P02+P03+P04+P05+P06+P07+P08+P09+P10+P11+P12+P13+P14+P15+P16+ P17+P18+P19+P20+P21+P22+P23+P24+P25+P26)*1.36; MAJCQX:MA(决策,3); STICKLINE(C>0,36,36,10,0),COLOR00FF00; STICKLINE(C>0,56,56,10,0),COLORFF00FF; STICKLINE(C>0,71,71,10,0),COLORRED; STICKLINE(C>0,44,44,10,0),COLORYELLOW;

编写方法:

ma1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10); P01:=IF(MA1>MA2,1,IF(MA2>MA1,-1,0)); MA3:=MA(CLOSE,3); MA4:=MA(CLOSE,5); P02:=IF(MA3>MA4,1,IF(MA4>MA3,-1,0)); MA5:=MA(CLOSE,12); MA6:=MA(CLOSE,50); P03:=IF(MA5>MA6,1,IF(MA6>MA5,-1,0)); {kdj} RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100; K:=ema(RSV,3); D:=EMA(K,3); P04:=IF(K>D,1,IF(D>K,-1,0)); {macd} dif:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); MacD:=(DIF-DEA)*2; P05:=IF(DIF>DEA,1,IF(DEA>DIF,-1,0)); {trix} TR2:=EMA(EMA(EMA(CLOSE,12),12),12); TRIX:=(TR-REF(TR,1))/REF(TR,1)*100; MATRIX:=MA(TRIX,9) ; P06:=IF(TRIX>MATRIX,1,IF(MATRIX>TRIX,-1,0)); {dmi} TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),7); HD :=HIGH-REF(HIGH,1); LD :=REF(LOW,1)-LOW; DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),7); DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),7); pdi:= DMP*100/TR; mdi:= DMM*100/TR; ADX:= EMA(ABS(MDI-PDI)/(MDI+PDI)*100,7); ADXR:=EMA(ADX,7); P07:=IF(PDI>MDI AND ADX>PDI AND ADX>50,3, IF(PDI<MDI AND ADX>MDI AND ADX>50,-3,0));{9} {rsi} LC:=REF(CLOSE,1); RSI1:=EMA(MAX(CLOSE-LC,0),5)/EMA(ABS(CLOSE-LC),5)*100;{10} P08:=IF(RSI1>80,1,IF(RSI1<20,-1,0));{10} {cci} TYP:=(HIGH+LOW+CLOSE)/3; CCI:=(TYP-MA(TYP,8))/(0.015*AVEDEV(TYP,8)); P09:=IF(CCI>180,2,IF(CCI<-180,-2,0));{12} {W%R} wr1:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100; P10:= IF(WR1>80,1,IF(WR1<20,-1,0));{13} {OSC} OSC:=100*(CLOSE-MA(CLOSE,20)); P11:=IF(OSC>0,1,IF(OSC<0,-1,0));{14} {mtm} MOM:=CLOSE-REF(CLOSE,7); P12:=IF(MOM>0,1,IF(MOM<0,-1,0));{15} {dpo} DPO:=CLOSE-REF(MA(CLOSE,11),11/2+1); P13:=IF(DPO>0,1,IF(DPO<0,-1,0));{16} {布林线} MB:=MA(CLOSE,12); R:=(CLOSE-MB)*(CLOSE-MB); X1:=MA(R,12); X2:=SQRT(X1); D1:=1; UPPER:=MB+(D1*X2); LOWER:=MB-(D1*X2); P14:=IF(CLOSE>UPPER,2,IF(CLOSE<LOWER,-2,0));{18} {BRAR} BR:=SUM(MAX(0,HIGH-REF(CLOSE,1)),14)/SUM(MAX(0,REF(CLOSE,1)-LOW),14)*100; AR:=SUM(HIGH-OPEN,14)/SUM(OPEN-LOW,14)*100; P15:=IF(BR>350 OR AR>180,3,IF(BR<45 OR AR<45,-3,0));{21} {VR} TH:=SUM(IF(CLOSE>REF(CLOSE,1),vol,0),14); TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),14); TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),14); VR:=0100*(TH*2+TQ)/(TL*2+TQ); P16:=IF(VR>350,3,IF(VR<45,-3,0));{24} {WVAD} WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,6)/10000; P17:=IF(WVAD>0,1,IF(WVAD<0,-1,0));{25} {emv} VOLUME:=MA(VOL,4)/VOL; MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW); EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,4),4); P18:=IF(EMV>0,1,IF(EMV<0,-1,0));{26} {obv} VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL); OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0); MaoBV:=EMA(OBV,24); P19:=IF(OBV>MAOBV,1,IF(OBV<MAOBV,-1,0));{27} {PVI} PVI:= PVI,COLORWHITE; MPVI:=EMA(PVI,24),COLORYELLOW; P20:=IF(PVI>MPVI,1,IF(PVI<MPVI,-1,0));{28} {NVI} NVI:=NVI,COLORWHITE; MNVI:=EMA(NVI,24),COLORYELLOW; P21:=IF(NVI>MNVI,2,IF(NVI<MNVI,-2,0));{30} {MASS} MASS:=SUM(MA(HIGH-LOW,9)/MA(MA(HIGH-LOW,9),9),25); MA7:=MA(CLOSE,9); P22:=IF(MA7>REF(MA7,1) AND MASS>26.5,2,IF(MA7<REF(MA7,1) AND MASS<26.5,-2,0));{32} {VHF} NUM:=ABS(HHV(HIGH,15)-LLV(LOW,15)); DEN:=SUM(ABS(CLOSE-REF(CLOSE,1)),15); VHF:=IF(DEN=0,0,NUM/DEN); VHF1:=EMA(VHF,240); P23:=IF(VHF>VHF1,1,IF(VHF<VHF1,-1,0));{33} {PUCU} PU:=MA(CLOSE,13); CU:=MA(VOL,13); PU1:=(PU-REF(PU,1))/REF(PU,1)*100; CU1:=(CU-REF(CU,1))/REF(CU,1)*100; 逆时针:=PU1+CU1; P24:=IF(逆时针>REF(逆时针,1),1,IF(逆时针<REF(逆时针,1),-1,0)); {asi} LC2:=REF(CLOSE,1); AA:=ABS(HIGH-LC2); BB:=ABS(LOW-LC2); CC:=ABS(HIGH-REF(LOW,1)); DD:=ABS(LC2-REF(OPEN,1)); R2:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4)); X01:=(CLOSE-LC2+(CLOSE-OPEN)/2+LC2-REF(OPEN,1)); SI:=16*X01/R2*MAX(AA,BB); ASI:=SUM(SI,0); MASI:=MA(ASI,6); P25:=IF(CLOSE<HHV(CLOSE,13) AND ASI=HHV(ASI,13),1,IF(CLOSE>LLV(CLOSE,13) AND ASI=LLV(ASI,13),-1,0)); {bias} BIAS1 :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100; P26:=IF(BIAS1>10,1,IF(BIAS1<-10,-1,0)); 决策:=(36+P01+P02+P03+P04+P05+P06+P07+P08+P09+P10+P11+P12+P13+P14+P15+P16+ P17+P18+P19+P20+P21+P22+P23+P24+P25+P26)*1.36; MAJCQX:=MA(决策,3); crOSS(决策,56) AND CROSS(MAJCQX,56);